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Preface

This paper deals with the practical exercises in the EndNote-course. The
exercises will help you build the bibliography given in the article entitled
User interface from Encyclopedia of computer science[1].

1 Bibliographies and reference lists

What is a bibliography?

A bibliography is a list of literature sharing some common aspect. This
might be a person, a subject, an area (national bibliographies) and others.

Within computer science there are a lot of bibliographies covering the
di�erent aspects of the �eld. Many of these bibliographies are available in a
common service called The Collection of Computer Science Bibliographies[2].

This service contains bibliographies in many categories: Arti�cial In-
telligence, Compiler Technology, Programming Languages and Type Theory,
Database Research, Distributed Systems, Networking and Telecommunica-
tions, Computer Graphics and Vision, Logic Programming, (Computational)
Mathematics, Neural Networks, . . .

All together more than 3 000 000 records (duplicates included).

What is a reference list? Why refer?

Your thesis could contain a bibliography as a part of your work, but this not
as important as a reference list.

The reference list in your thesis should contain information on every
document that you either cite, are referring to or from which you use ideas,
illustrations, graphs, statistics or other results.

The body text must contain citations which are pointers to the reference
list.

Without a reference list, a thesis is not �nished. When working with
research you always base your work more or less on previous works done by
others. If you don't cite them when you do, it will be considered theft.

Now, how far should you go in citing? This varies from discipline to
discipline.

When giving de�nitions of concepts you should always cite the source,
because this tells the reader what context your operate within.

What might be considered as common knowledge, like the fact that the
earth moves around the sun[3], need not be cited. What is common knowl-
edge in one discipline, might not be in another. It also depends on for whom
you are writing.

The importance of consistent and correct references

The purpose of the reference list is to show what previous research your own
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work is based on and to give the readers of your work a chance to evaluate
it.

This means that references must contain the necessary and su�cient
information elements to identify and locate the described document.

This course deals with the question of making a proper reference list
using the tool EndNote.

2 Exercise 1: Building an EndNote library

2.1 Organizing the references

Groups and libraries

In EndNote the references are collected in one or more libraries. In this course
we will use one library only, but if you are working on di�erent projects or
articles it might be convenient to use di�erent libraries, one for each project
or article.

On the other hand, you may collocate references into several groups and
subgroups of interest. A reference may be member of more than one group.

The purpose of this exercise is to build a library consisting of the 11
references given in [1].

Start up

Fire up EndNote. You will get these three options:
• Learn about EndNote
• Create a new library
• Open an existing library

Select the second option. You will enter into a �le selection window. Create
a new folder called endnote in your home directory and let thecourse be the
library name.

Preferences

If you have more than one library you may mark thecourse as your default
library choosing Edit > Preferences and then click Libraries, Open the
speci�ed libraries and �nally clicking Add open library.

Observe some other possibilities in the preferences:
• Display fonts. Choose a comfortable text font and size.
• References types. Here you may deactivate the reference types you

will never use from type menus popping up in the system. You may also
deactivate the �elds you'll never use in the reference types. Postpone doing
this till you are more familiar with EndNote.
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2.2 References

The references should give the reader a chance to locate the cited documents.
This means that certain information elements are mandatory. What elements
are needed vary from document type to document type.

Give the command References > New reference.
EndNote has a menu that covers a lot of document types, but unfor-

tunately no information on which elements are mandatory and which are
optional.

2.3 The most important reference types in EndNote

Journal article
Mandatory: author, title, journal, year,
Recommended: volume, issue, pages

Comment : Some journals have a running page numbering going through all
the issues in a volume and the last issue in a volume usually contains an
author index. If this is not the case you should include issue and pages in
your reference.
Examples: [4, 5, 6, 7, 8, 9].

Book
Mandatory: author, title, publisher, year,
Recommended: edition

Comment : Edition should be included when important to di�erentiate. Ex-
amples: [10, 11, 12, 13].

Book section
Mandatory: author, chapter title, book title,
Recommended: year, pages, publisher, editor

Example:[14].

Conference paper
Mandatory: author, paper title, conference title,
Recommended: year, pages, publisher

Example: [15].

Thesis

Mandatory: author, title, university, year,

Comment : EndNote does not di�erentiate between master and doctoral the-
sis. Example: [16].

Report
Mandatory: author, title, institution, year,
Recommended: report number

Example:This technical report[17] was found in The Collection of Computer
Science Bibliographies.
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Field Data

author D.R. Olsen or Olsen, D.R.

year 1992

title User interface management systems: models and algorithms

city San Francisco

publisher Morgan Kaufmann

Table 1: Fields and the data to �ll in for the Olsen reference.

Web page
Mandatory: title, url, date,
Recommended: author/corporate body responsible for the page

Comment : Date is important by several reasons. First of all:web pages have
a tendency to change over time, you should document which version (date)
you are referring to. Second: the documents often change their URLs.

It is also recommended that you keep a printed copy of the page for later
control. Examples: [2, 3].

2.4 Writing references from scratch

If you do not have any automatic sources, you will have to enter the infor-
mation into EndNote yourself. In the user interface-bibliography there are
two references that we can not �nd in any external source [11, 14].

We start with [11]. Choose References > New reference (or simply
Ctrl-N). Select document type from the pull down menu (Book). Use TAB
to move from one �eld to the next and shift-TAB to move to the previous
�eld. Table 1 contains the data to �ll in.

You may use the Show/hide empty �elds-button (if it is shown in the
upper right corner of the reference window). Save the reference by the com-
mand Ctrl-S and close the window by Ctrl-W.

The next reference is [14]. This is a chapter in a book. Start the regis-
tration by giving the command Ctrl-N and select the document type Book
section.

If the author name is known by EndNote from an earlier reference, the
program will suggest a completion. If it is a new name, the text will be in
red colour. These two features will help you normalise the author names.
Table 2 contains the data to �ll into the reference �elds.
Finish the registration by Ctrl-S and Ctrl-W.

Mark one of the references and choose bibliography style from the pull-
down menu in the upper right. Try annotated and numbered and study the
preview. Select Select another style and choose harvard from the list. Take
a look at the preview of the reference to see what it will look like in the
bibliography using this style. Try another style also.
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Field Data

author Hutchins, E.L. RET
Hollan, J.D. RET
Norman, D.A.

year 1986

title Direct manipulation interfaces

editor Norman, D.A RET
Draper, S.W.

book title User centered system design: new
perspectives on human-computer interaction

city Hillsdale, NJ

publisher Lawrence Erlbaum

pages 87-124

Table 2: Fields and data for the Hutchins reference.

2.5 Exporting references from databases to EndNote

Many of the relevant database sources have options that let you download
references more or less automatically, directly into EndNote.

Usually you will download the reference in parallel with downloading the
full document. Make it a habit to fetch the reference data alongside fetching
the document.

During the import EndNote uses special �lters which identify the infor-
mation elements and place them in the correct �elds. Some of these �lters
aren't very accurate, but there is a possibility to adjust/edit the �lters in
EndNote. This is not a theme in this course, use the EndNote-manual.

ACM Digital Library � ACM DL

We will get two of the references from ACM DL[5, 6].
Use the browser to go to the Informatics library home page. Select ACM

Digital Library.
For Computing surveys: Click the link Journals, then on the journal title

and from there to correct contents page.
When we have found the correct reference in the contents, click the article

title to see the full reference. On the right side of the screen there is a
small window entitled Tools and Resources. Under Export Formats, choose
EndNote. The coded reference is now showing in a new window, and you
must scroll down to click download.

If prompted to open or save, choose Open and select the correct library
from EndNote. The reference will be shown in a separate window. Inspect
the di�erent �elds of the reference. ACM DL exports abbreviated journal
title (ACM Comp. Surv.), change this to full title (ACM Computing Sur-
veys).

The other reference belongs to the journal series ACM Transactions.
Follow the same procedure to copy the reference over to EndNote. Check
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the journal title.

IEEE Xplore

The next reference is [9]. Select IEEE Xplore from the library home page.
Click the Journals and magazines and search for computer. Select the �rst
journal in the list and choose the correct year and issue (1983,8). Scroll down
the contents to �nd the correct article and click the title.

Click the button Download citation. Choose Citation and then Endnote
... from the radio buttons. Click the button Download citation.

If I get the options to open the �le or to save it, I choose to open. The
reference will be then be imported into EndNote. In your browser, you can
de�ne �les with the extension RIS to be opened with EndNote.

Inspec

We could have found [7] in the IEEE Xplore, but as an exercise we will use
Inspec. Start up Inspec from the library home page.

Select the option Advanced Search and search the phrase xerox star.
Scroll down the hit list to �nd the correct reference. Mark the reference
in the box to the left of the reference. Mark the references to import. Select
Export in the horiontal menu above the references.

In the new window: select EndNote in the pull down menu, citation as
format and click the Export citation button.

Web of Science

We will now get the reference [4] from the Web of Science. Select this
database from the library home page. This will bring you to a search page.

Enter foley j* in the �rst �eld and select author. Then enter 1987 in
the next �eld and select Year published. Finally, enter Scienti�c American
in the third �eld and select Publication name.

A click on the Search button will result in exactly one hit. Mark this
reference and click the EndNote button in top of the list. Eventually, click
Export. The reference is imported into EndNote. Look at it and make
changes if needed.

Google Scholar

We will get the reference [8] from Google Scholar. To do this, you must
�rst change the Scholar settings: Under the headline bibliography manager
choose Show links to import citations into EndNote. Now you can search for
the reference, and click the link Import into EndNote

The library catalogue � Oria

The last three references [10, 12, 13] are books and we will �nd them in the
library catalogue, Oria.

Select Oria � Advanced search from the library home page.
Select as author/contributor contains from the �rst �eld's drop down
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menus, and enter foley. Next, select in the title contains and enter computer
graphics. Click Search.

From the hit list, select the correct edition (1990) and click the star next
to the title.

Repeat the procedure for the next two references.
To move the references over to EndNote, do the following: Click the star

in the upper right corner of the screen to see your basket. Select the three
references.

In the drop down menu, select Push to EndNote, then click Go. In the
appearing window, click OK to select UTF-8 encoding. If asked to open or
save, click Open.

Check the references after they have been imported to EndNote. You
might for example remove all the keywords.

We have now built the bibliography with the 11 references.

2.6 Changing style sheets to include URLs

The layout of the references in the reference lists is based on style sheets.
There is a style sheet for every reference type under every bibliography style.

None of the styles include the �elds URL and Access Date, but you may
edit the style sheets so that these �elds will appear.

In EndNote choose the command Edit > Output styles > Edit �Numbered�.
You will get a window with several options in the left margin. Select

Templates under Bibliography. In the main window you will see the styles
for each reference type.

Every style include �eld names (author, title and so on), and the char-
acters separating the �elds (period, comma, colon, blanks . . . ).

When editing, you type your characters directly into the style, but when
inserting �elds it is recommended that you select the �eld name from the
menu that appears when you click the button Insert �eld.

Usually the URL and access date is placed at the bottom of the reference,
on a separate line, like this:

The Book-style looks like this (on one line) before editing:

Author, Title|. Edition ed|. Series Title|, ed. Series Editor|.

Vol. Volume|. Year|, City|: Publisher|. Number of Pages|.

After insertion of a new line (End of paragraph, URL and Access Date
from the Insert �eld menu (and with parenthesis around the date), it will
look like this (actually two lines):

Author, Title|. Edition ed|. Series Title|, ed. Series Editor|.

Vol. Volume|. Year|, City|: Publisher|. Number of Pages|.

URL (Access Date)
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The new edited style must be saved under i new name, e.g. Numbered
copy. You may read more about this in the chapter Bibliographic styles in
the Help menu.

2.7 Searching databases from Endnote � downloading refer-
ences

There is a possibility to search bibliographic databases from within EndNote.
Usually it is better to use the original interface of the databases and export
data from them into EndNote.

Choose the command Tools > Online Search. You will now get a list
of databases in which you may search from within EndNote. Most of them
are local library catalogues and most of them are irrelevant seen from the
computer science �eld.

Please note that neither ACM Digital library, IEEE Xplore nor Inspec
are searchable from EndNote.

2.8 Edit, sort, search and collocate references

When you are inside EndNote, you may manipulate the references in di�erent
ways:

Navigating

Choose All references. Mark one reference in the list. Up/down arrows on
the keyboard move in the list.

If you type something when the reference window is active, the program
will jump to the �rst reference that matches what you have typed. The
functionality depends on how the list is sorted.

RETURN opens the marked reference.

Preview window

The Preview window also has a Reference TAB for editing a reference without
opening a new window.

PDF & Quick edit

If you have stored a PDF in your reference, you may use this window to
annotate the PDF.

Sorting

The simplest way to sort the references is to click on the column headers.
An extra click on a header reverses the sorting order.

You may also sort by giving the command Tools > Sort library ...

and then one or more sorting �elds and sort direction for each �eld.

Searching

You may start search in your library in di�erent ways: select theQuick Search
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or Show Search Panel in the menu bar; choose Tools > Search references

or simply type Ctrl-F. Enter the text computer and click Search. The hit
list contains all references with the word computer in one or several �elds.

Repeat the search, but this time limit the search to the title �eld.
If you use the label -�eld to enter your own keywords, you will then later

easily �nd references relevant for a subject, a chapter in the thesis or the
article you are writing. We do not recommend using the keyword -�eld for this
purpose, as the imported references often will bring the database keywords
into the keyword-�eld.

Marking several references

You may mark a sequence of references by the clicking the �rst and shift-
clicking the last reference in the sequence.

If you want to select several references that are not in sequence: use
Ctrl-click.

Collocating and grouping references

Using search to get a hitlist you collocate references for further handling,
like exporting, deleting, printing and so on. Note that when you have a
hitlist, you may select Convert to Smart Group from the Options menu.
This will create a dynamic reference group which contains the hit list and will
be automatically kept up-to-date with new references satisfying the search
criteria.

You may also group references by theme or interest, for example the
references relevant for a certain document you are working on. By selecting
Groups > Create group you may create a group with a certain name. To
include references in your group, you may drag them over or you may mark
them, right-click and select the command Add references to and then the
relevant group name. A reference may be a member of severals groups.

Printing

If you want to print all your references or a selection (see above) you �rst
decide your bibliography style (numbered, Harvard, ...) and then File >
print.

Remove duplicates

When you have imported references en bloc from di�erent sources, your
EndNote-library might well include duplicate references.

EndNote has a tool to remove duplicates.
If you choose References > Find duplicates, the program will use

some pre-chosen criteria to compare references and �nd possible duplicate
candidates. You may de�ne your own duplicate criteria by selecting Edit

> Preferences and then Duplicates.
If the program �nds duplicates you will get the candidates in a special

hit list where you can inspect them and eventually remove them. Note: The
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manual advises against removing references that have already been cited in a
document.

Normalising author names

You should normalise the author names. Di�erent name forms a�ect the
sorting order in the list.

Importing pdf-�les

Select one or more references, rightclick and choose Find full text to make
EndNote search for PDFs. If the search is successful, the �le will be added to
the reference in question. You may also add �les to the reference manually.

You may import pdf �les to your EndNote-library. The program will
then try to interpret the document and construct a reference. From the
File menu, select Import > File or Folder. Set Import option to PDF.

3 Exercise 2:Using EndNote and Word

If EndNote is correctly installed, an EndNote menu should appear under a
EndNote pane in the banner.

Master thesis style sheet

There exists a word style sheet for master thesis.

Working document

In this exercise you start by copying the text from
http://folk.uio.no/knuthe/endnote/tekst.html

into a Word document.
The next step is to replace the existing references (enclosed in double

asterixs (*)) with EndNote-references.
Make sure that EndNote is running and choose the bibliography style

Numbered in the pull down menu up right.

Con�gure

First, note that the EndNote menu includes a choice for Preferences (to the
far right). Selecting this you may control options concerning the communi-
cation between Word and EndNote.

You may control whether Word and EndNote should open and close
simultaneously, you may de�ne keyboard short-cuts to �nd, edit and insert
references and more.

3.1 Find references and include citations

Place the cursor where you want your citation to be inserted (in this case to
left of **Shneiderman,1992**). Choose the command Insert Citation or
click on the magnifying glass in the EndNote menu.
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Enter the text shneiderman in the search �eld and click Search. You will
get two hits. Mark the book published in 1992.

Click the Insert button. Depending on the bibliography style you have
chosen, the result may vary. If you have chosen Numbered, you will see [1]
where you originally put the cursor.

Now, remove the text **Shneiderman, 1992**.

3.2 The reference list header

In the Word program: click the little arrow inside the Bibliography option
in the EndNote menu. Select the Layout pane in the window that appears
and enter the text of your choice in the Bibliography title �eld.

3.3 Turning on/o� continuous updating of the references list

As you write and include citations the references list is updated. When the
list becomes long, this updating takes time, which is annoying. You can
turn o� automatic updating by selecting Bibliography (the little arrow) in
the EndNote menu in Word and then the Instant formatting pane. A button
there will turn instant formatting on/o�.

If it is turned o�, you must click Update citations and bibliography to get
an updated version.

3.4 Edit the citation

Every now and then you have a need to edit the citation. You might want
to exclude the author name, the year or you want to refer to a certain page
in the reference, like this

• as Shneiderman wrote (1992)
• in 1992 Shneiderman wrote (p.64)
• (Shneiderman, 1992, p.64)

To edit a citation you must �rst select the command Convert Citations

and Bibliography from the EndNote menu and then Convert to unformatted

Citations. The citation will then appear in another syntax. Please note the
number with the '#' pre�x. This is the database record number and should
not be touched.

You may mark the author or year and drag them outside the citation.
If you want to add a certain page number to the citation, type it after the
record number. Here is an example:

{Shneiderman, 1992 #77, p. 64}

when formated, the citation it will apppear like this:

(Shneiderman, 1992, p. 64)

12



You may not type anything in the area limited by author and record
number.

If you want to add some text as a pre�x to the author name, you must
�nish it with a backslash. Here is an example:

{see also \Shneiderman, 1992 #77, p. 64}

will appear as this when formated:

(see also Shneiderman, 1992, p. 64)

When you have several citations inside the parentesis, these are separated
by semicolon. The same rules of editing apply to each one of them.

When you have �nished editing the citations, choose Update Citations

and Bibliography from the EndNote menu.

The next references

Continue to insert the rest of the citations in the text until you arrive at a
citation that contains two references.

In this case, insert the �rst reference in the normal way. The cursor will
be standing close to the right of the citation. Detect the next reference in
EndNote without moving the cursor. The result is that the two references
are merged within the same brackets. A blank between the citations would
lead to two separate citations.

Continue the exercise by inserting the rest of the citations.

3.5 Changing the bibliography style

If you scroll down in your document, you will see the reference list shaded (if
you try to put the cursor inside). This means that the list is automatically
generated and you should not try to edit it.

Please note that the citations are numbered with increasing numbers
and that the references are sorted by this number and not alphabetically by
author. This is due to the selection of Numbered as bibliography style.

You may change the bibliography style by chosing from the pulldown
menu Style. Try selecting the style Harvard, and study the results in the
document, both the citations and the reference list.

There are over 2000 bibliography styles in EndNote, many of them spe-
cially suited for the styles required by di�erent journals.

3.6 Pictures, tables, diagrams

Through EndNote you may also take control over your illustrations.
One short example: Activate EndNote and use for instance the Snipping

toolto save a picture of the screen. Save the picture in a �le in a suitable
format (bmp, gif, jpeg, png, ti�).
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Go back to EndNote to register the picture. Make a new reference by
Ctrl-N, select reference type Figure. Enter yourself as Creator and 2012 as
the year. Tab down to the Figure �eld. Select References > Figure >
Attach Figure ... and select your saved picture �le. A miniature picture
will appear in the Figure �eld.

Fill in some text as the picture caption.
Activate Word and insert the �gure in the document in this way:
Place the cursor where you want the �gure reference to appear. Select

the EndNote command Insert Citation > Find figure. You probably
will �nd only one picture.

Mark this picture and click Insert. The picture will now be included in
the document and you will get a reference to it where the cursor was placed.

If you change the caption text in EndNote, this will unfortunately have
no consquences in the Word document. You will have to remove the picture
and then insert it again.

In a similar way you may handle tables (Excel) and other illustrations in
EndNote. More on this topic in the Getting started guide.

14



References

[1] Robert J. K. Jacob. User interface. In Anthony Ralston, Edwin D.
Reilly, and David Hemmendinger, editors, Encyclopedia of computer
science, pages 1821 � 1826. Nature publishing Group, 4 edition, 2000.

[2] Alf-Christian Achilles and Paul Ortyl. The Collection of Computer
Science Bibliographies.
http://liinwww.ira.uka.de/bibliography/index.html (2015-08-25).

[3] Nicolaus Copernicus. De Revolutionibus Orbium Coelestium. apud. Ioh.
Petreium, 1543.
http://ads.harvard.edu/books/1543droc.book (2015-08-25).

[4] James D. Foley. Interfaces for advanced computing. Scienti�c American,
257(4):127�135, 1987.

[5] H. Rex Hartson and Deborah Hix. Human-computer interface devel-
opment: concepts and systems for its management. ACM Computing
Surveys, 21(1):5�92, 1989.

[6] Robert J. K. Jacob. A speci�cation language for direct-manipulation
user interfaces. ACM Transaction on Graphics, 5(4):283�317, 1986.

[7] J. Johnson, T. L. Roberts, W. Verplank, D. C. Smith, C. H. Irby,
M. Beard, and K. Mackey. The Xerox Star: a retrospective. Computer,
22(9):28�29, 1989.

[8] Brad A. Myers. User interface software tools. ACM Transactions on
Computer-Human Interaction, 2(1):64�103, 1995. 200971.

[9] Ben Shneiderman. Direct manipulation: A step beyond programming
languages. Computer, 16(8):57�69, 1983. 0018-9162.

[10] James D. Foley. Computer graphics: principles and practice. Addison-
Wesley, Reading, Mass., 1990.

[11] D.R. Olsen. User interface management systems: models and algo-
rithms. Morgan Kaufmann, San Francisco, 1992.

[12] Ben Shneiderman. Designing the user interface: strategies for e�ective
human-computer interaction. Addison-Wesley, Reading, Mass., 1992.

[13] Neal Stephenson. In the beginning ...was the command line. Avon Books,
New York, 1999.

[14] E.L. Hutchins, J.D. Hollan, and Donald A. Norman. Direct manipula-
tion interfaces. In Donald A. Norman and Stephen W. Draper, editors,
User centered system design: new perspectives on human-computer in-
teraction, pages 87�124. Lawrence Erlbaum, Hillsdale, 1986.

15



[15] Andrew J. Ko and Brad A. Myers. Barista: An implementation frame-
work for enabling new tools, interaction techniques and views in code
editors. In CHI '06: Proceedings of the SIGCHI conference on Human
Factors in computing systems, pages 387�396, New York, NY, USA,
2006. ACM Press.

[16] Merethe Johnsen. Programvare for programmeringsmesterskap, 2006.
Hovedoppgave i informatikk - Universitetet i Oslo, 2006.

[17] H. Rex Hartson and Kevin A. Mayo. Synthesis-oriented situational
analysis as an alternative to analytic evaluation for iterative user inter-
face design. Technical Report TR-93-09, Virginia Polytechnic Inst. and
State University, 1993.

August 2015
/undervisning/endnote/kurshefte/endnotefolder.tex

16


